MongoDB Java Driver Core

The Java operations layer for the MongoDB Java Driver. Third parties can wrap this layer to provide custom higher-level APIs
org.mongodb

mongodb

Как подключить последнюю версию

<!-- https://jarcasting.com/artifacts/org.mongodb/mongodb-driver-core/ -->
<dependency>
    <groupId>org.mongodb</groupId>
    <artifactId>mongodb-driver-core</artifactId>
    <version>4.4.1</version>
</dependency>
// https://jarcasting.com/artifacts/org.mongodb/mongodb-driver-core/
implementation 'org.mongodb:mongodb-driver-core:4.4.1'
// https://jarcasting.com/artifacts/org.mongodb/mongodb-driver-core/
implementation ("org.mongodb:mongodb-driver-core:4.4.1")
'org.mongodb:mongodb-driver-core:jar:4.4.1'
<dependency org="org.mongodb" name="mongodb-driver-core" rev="4.4.1">
  <artifact name="mongodb-driver-core" type="jar" />
</dependency>
@Grapes(
@Grab(group='org.mongodb', module='mongodb-driver-core', version='4.4.1')
)
libraryDependencies += "org.mongodb" % "mongodb-driver-core" % "4.4.1"
[org.mongodb/mongodb-driver-core "4.4.1"]

Основная информация о библиотеке

Группа

Группа

org.mongodb
Идентификатор

Идентификатор

mongodb-driver-core
Последняя версия

Последняя версия

4.4.1
Дата

Дата

Тип

Тип

jar
Описание

Описание

MongoDB Java Driver Core
The Java operations layer for the MongoDB Java Driver. Third parties can wrap this layer to provide custom higher-level APIs
Ссылка на сайт

Ссылка на сайт

http://www.mongodb.org
Система контроля версий

Система контроля версий

https://github.com/mongodb/mongo-java-driver
Лицензии

Лицензии

Зависимости

compile (5)

Идентификатор библиотеки Тип Версия
org.slf4j : slf4j-api Необязательный jar 1.7.6
org.mongodb : bson jar 4.4.1
io.netty : netty-buffer Необязательный jar 4.1.43.Final
io.netty : netty-transport Необязательный jar 4.1.43.Final
io.netty : netty-handler Необязательный jar 4.1.43.Final

runtime (4)

Идентификатор библиотеки Тип Версия
com.github.jnr : jnr-unixsocket Необязательный jar 0.18
org.xerial.snappy : snappy-java Необязательный jar 1.1.4
com.github.luben : zstd-jni Необязательный jar 1.3.8-3
org.mongodb : mongodb-crypt Необязательный jar 1.3.0

Модули Проекта

Данный проект не имеет модулей.

Версии библиотеки

Версия
4.4.1
4.4.0
4.4.0-beta2
4.4.0-beta1
4.3.4
4.3.3
4.3.2
4.3.1
4.3.0
4.3.0-beta4
4.3.0-beta3
4.3.0-beta2
4.3.0-beta1
4.2.3
4.2.2
4.2.1
4.2.0
4.2.0-beta1
4.1.2
4.1.1
4.1.0
4.1.0-rc0
4.1.0-beta2
4.1.0-beta1
4.0.6
4.0.5
4.0.4
4.0.3
4.0.2
4.0.1
4.0.0
4.0.0-rc0
4.0.0-beta1
3.12.10
3.12.9
3.12.8
3.12.7
3.12.6
3.12.5
3.12.4
3.12.3
3.12.2
3.12.1
3.12.0
3.11.3
3.11.2
3.11.1
3.11.0
3.11.0-rc0
3.11.0-beta4
3.11.0-beta3
3.11.0-beta2
3.11.0-beta1
3.10.2
3.10.1
3.10.0
3.9.1
3.9.0
3.9.0-rc0
3.8.2
3.8.1
3.8.0
3.8.0-beta3
3.8.0-beta2
3.8.0-beta1
3.7.1
3.7.0
3.7.0-rc0
3.6.4
3.6.3
3.6.2
3.6.1
3.6.0
3.6.0-rc1
3.6.0-rc0
3.6.0-beta2
3.6.0-beta1
3.5.0
3.5.0-alpha1
3.4.3
3.4.2
3.4.1
3.4.0
3.4.0-rc1
3.4.0-beta1
3.3.0
3.2.2
3.2.1
3.2.0
3.2.0-rc0
3.1.1
3.1.0
3.1.0-rc0
3.0.4
3.0.3
3.0.2
3.0.1
3.0.0
3.0.0-rc1
3.0.0-rc0
3.0.0-beta3
3.0.0-beta2
3.0.0-beta1